Mollie - IDEAL: minor disruption – Incident details

All systems operational

IDEAL: minor disruption

Resolved
Degraded performance
Started 4 days agoLasted 10 minutes

Affected

Local payment methods

Degraded performance from 4:25 PM to 4:35 PM

iDEAL

Degraded performance from 4:25 PM to 4:35 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We have identified a minor disruption affecting IDEAL payments. You may see a decline in successful payments as consumers may be unable to pay using this payment method. We are working to resolve the issue and will provide updates as they become available.