External - iDEAL: Triodos scheduled maintenance
Scheduled for Saturday 14 June 2025 at 22:30 – Sunday 15 June 2025 at 06:00
Affects
Local payment methods
Under maintenance from 10:30 PM to 6:00 AM
iDEAL
Under maintenance from 10:30 PM to 6:00 AM
Completed
Sunday 15 June 2025 at 06:00Completed
Sunday 15 June 2025 at 06:00Maintenance has completed successfully
In progress
Saturday 14 June 2025 at 22:30In progress
Saturday 14 June 2025 at 22:30Maintenance is now in progress
Planned
Saturday 14 June 2025 at 22:30Planned
Saturday 14 June 2025 at 22:30A maintenance window external to our platform has been announced for iDEAL payments issued by Triodos.
During this time, you may experience intermittent unavailability and reduced conversion rates.