External - Belfius: Scheduled Maintenance
Scheduled for Saturday 15 March 2025 at 22:30 – Sunday 16 March 2025 at 17:00
Affects
Local payment methods
Under maintenance from 10:30 PM to 5:00 PM
Belfius
Under maintenance from 10:30 PM to 5:00 PM
Completed
Sunday 16 March 2025 at 17:00Completed
Sunday 16 March 2025 at 17:00Maintenance has completed successfully
In progress
Saturday 15 March 2025 at 22:30In progress
Saturday 15 March 2025 at 22:30Maintenance is now in progress
Planned
Saturday 15 March 2025 at 22:30Planned
Saturday 15 March 2025 at 22:30A scheduled maintenance external to our platform has been planned for Belfius.
You might experience intermittent unavailability and a decrease in conversion for Belfius payments between Saturday, 23:30 CET and Sunday, 18:00 CET.