Scheduled for Tuesday 30 July 2024 at 20:30 – 21:30
Affects
Local payment methods
Under maintenance from 8:30 PM to 9:30 PM
Twint
Under maintenance from 8:30 PM to 9:30 PM
Updates
Completed
Tuesday 30 July 2024 at 21:30
Completed
Tuesday 30 July 2024 at 21:30
Maintenance has completed successfully
In progress
Tuesday 30 July 2024 at 20:30
In progress
Tuesday 30 July 2024 at 20:30
Maintenance is now in progress
Planned
Tuesday 30 July 2024 at 20:30
Planned
Tuesday 30 July 2024 at 20:30
A scheduled maintenance window has been announced for Twint.
You might experience intermittent unavailability and a decrease in conversion for Twint payments between 2024-07-30 22:30 (CEST) and and 2024-07-30 23:30 (CEST).