Scheduled for Saturday 29 June 2024 at 20:00 – Sunday 30 June 2024 at 01:00
Affects
Local payment methods
Under maintenance from 8:00 PM to 1:00 AM
Twint
Under maintenance from 8:00 PM to 1:00 AM
Updates
Completed
Sunday 30 June 2024 at 01:00
Completed
Sunday 30 June 2024 at 01:00
Maintenance has completed successfully
In progress
Saturday 29 June 2024 at 20:00
In progress
Saturday 29 June 2024 at 20:00
Maintenance is now in progress
Planned
Saturday 29 June 2024 at 20:00
Planned
Saturday 29 June 2024 at 20:00
A scheduled maintenance window has been announced for TWINT.
You might experience intermittent unavailability and a decrease in conversion for TWINT payments between 2024-06-29 22:00:00 & 2024-06-30 03:00:00 CEST.