All systems operational

Bancontact: Scheduled maintenance

Completed
Scheduled for Tuesday 18 June 2024 at 01:00 – 05:00

Affects

Local payment methods
Bancontact
Updates
  • Completed
    Tuesday 18 June 2024 at 05:00
    Completed
    Tuesday 18 June 2024 at 05:00
    Maintenance has completed successfully
  • In progress
    Tuesday 18 June 2024 at 01:00
    In progress
    Tuesday 18 June 2024 at 01:00
    Maintenance is now in progress
  • Planned
    Tuesday 18 June 2024 at 01:00
    Planned
    Tuesday 18 June 2024 at 01:00

    A scheduled maintenance window has been announced for Bancontact.

    You may experience intermittent unavailability and a decrease in conversion for Bancontact Payments between 03:00 (CEST) and 07:00 (CEST) on June 18th.