External - Bancontact Scheduled Maintenance
Scheduled for Sunday 26 April 2026 at 07:00 – 10:00
Affects
Local payment methods
Under maintenance from 7:00 AM to 10:00 AM
Bancontact
Under maintenance from 7:00 AM to 10:00 AM
Completed
Sunday 26 April 2026 at 10:00Completed
Sunday 26 April 2026 at 10:00Maintenance has completed successfully
In progress
Sunday 26 April 2026 at 07:00In progress
Sunday 26 April 2026 at 07:00Maintenance is now in progress
Planned
Sunday 26 April 2026 at 07:00Planned
Sunday 26 April 2026 at 07:00A maintenance window external to our platform has been announced for Bancontact.
You might experience intermittent unavailability and a decrease in conversion for Bancontact payments.