Mollie - SEPA Direct Debit: payments not marked as paid – Incident details

All systems operational

SEPA Direct Debit: payments not marked as paid

Resolved
Degraded performance
Started about 14 hours agoLasted about 4 hours

Affected

Local payment methods

Degraded performance from 8:30 AM to 12:32 PM

SEPA Direct Debit

Degraded performance from 8:30 AM to 12:32 PM

Updates
  • Resolved
    Resolved

    We’ve implemented a fix and are seeing the first payments update to the correct status. It may take several hours for all payments to reflect the correct status as our systems are catching up.

  • Identified
    Identified

    We have identified the issue.

    We are working to resolve the issue and will provide updates as they become available.

  • Investigating
    Investigating

    We are currently investigating an issue affecting SEPA Direct Debit payments made after 31 January that may not be marked as paid in our platform.

    We will provide updates as they become available.