External - Klarna Merchant Portal: Scheduled Maintenance
Scheduled for Thursday 08 May 2025 at 06:00 – 07:00
Affects
International payment methods
Under maintenance from 6:00 AM to 7:00 AM
Klarna
Under maintenance from 6:00 AM to 7:00 AM
Completed
Thursday 08 May 2025 at 07:00Completed
Thursday 08 May 2025 at 07:00Maintenance has completed successfully
In progress
Thursday 08 May 2025 at 06:00In progress
Thursday 08 May 2025 at 06:00Maintenance is now in progress
Planned
Thursday 08 May 2025 at 06:00Planned
Thursday 08 May 2025 at 06:00Klarna has announced a scheduled maintenance window external to our platform for the Klarna Merchant Portal.
During this maintenance window, users will be unable to access the Klarna Merchant Portal.