Mollie - External - Klarna: major disruption – Incident details

All systems operational

External - Klarna: major disruption

Resolved
Major outage
Started 9 days agoLasted 14 minutes

Affected

International payment methods

Major outage from 10:19 AM to 10:33 AM

Klarna

Major outage from 10:19 AM to 10:33 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We have identified a major disruption external to our platform affecting Klarna payments.

    Consumers may experience failures when attempting to pay using this payment method.

    We will provide further updates as soon as we have more information.