Mollie - External - iDEAL: major disruption at ASN Bank, SNS and RegioBank – Incident details

All systems operational

External - iDEAL: major disruption at ASN Bank, SNS and RegioBank

Resolved
Degraded performance
Started 1 day agoLasted about 3 hours

Affected

Local payment methods

Degraded performance from 8:10 AM to 11:33 AM

iDEAL

Degraded performance from 8:10 AM to 11:33 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    ASN Bank, SNS and RegioBank are experiencing a major disruption affecting iDEAL payments, which could cause consumers to experience failures when attempting to complete payments.

    We will provide further updates as soon as we have more information.