Mollie - External - iDEAL: full disruption at ABN AMRO – Incident details

All systems operational

External - iDEAL: full disruption at ABN AMRO

Resolved
Degraded performance
Started 1 day agoLasted 28 minutes

Affected

Local payment methods

Degraded performance from 4:44 PM to 5:12 PM

iDEAL

Degraded performance from 4:44 PM to 5:12 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    ABN AMRO is experiencing a full disruption affecting iDEAL payments and consumers will experience failures attempting to complete payments.

    We will provide further updates as soon as we have more information.