Scheduled for Friday 31 January 2025 at 01:00 – 02:00
Affects
Local payment methods
Under maintenance from 1:00 AM to 2:00 AM
iDEAL
Under maintenance from 1:00 AM to 2:00 AM
Updates
Completed
Friday 31 January 2025 at 02:00
Completed
Friday 31 January 2025 at 02:00
Maintenance has completed successfully
In progress
Friday 31 January 2025 at 01:00
In progress
Friday 31 January 2025 at 01:00
Maintenance is now in progress
Planned
Friday 31 January 2025 at 01:00
Planned
Friday 31 January 2025 at 01:00
ABN AMRO has announced a scheduled maintenance window for iDEAL payments.
You might experience intermittent unavailability and a decrease in conversion for iDEAL Payments for customers of ABN AMRO between 02:00 and 03:00 CET. ABN AMRO expects a maximum of 20 minutes downtime during the provided time interval.