Scheduled for Tuesday 29 October 2024 at 04:00 – 06:00
Affects
Local payment methods
Under maintenance from 4:00 AM to 6:00 AM
Bancontact
Under maintenance from 4:00 AM to 6:00 AM
Updates
Completed
Tuesday 29 October 2024 at 06:00
Completed
Tuesday 29 October 2024 at 06:00
Maintenance has completed successfully
In progress
Tuesday 29 October 2024 at 04:00
In progress
Tuesday 29 October 2024 at 04:00
Maintenance is now in progress
Planned
Tuesday 29 October 2024 at 04:00
Planned
Tuesday 29 October 2024 at 04:00
A scheduled maintenance window has been announced for Bancontact.
You might experience intermittent unavailability and a decrease in conversion for Bancontact Payments between 05:00 (CET) and 07:00 (CET) on 29 October 2024.