Mollie - SEPA Bank Transfer : Minor disruption – Incident details

All systems operational

SEPA Bank Transfer : Minor disruption

Resolved
Degraded performance
Started 10 days agoLasted about 2 hours

Affected

Local payment methods

Degraded performance from 9:40 AM to 11:39 AM

SEPA Bank Transfer

Degraded performance from 9:40 AM to 11:39 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified a disruption affecting SEPA bank transfer payments.

    While incoming bank transfer payments are being successfully received, we are currently experiencing a delay settling these funds to your balance. As a result, the settlement of bank transfer funds may be delayed.

    Our engineering team is actively working on a resolution, and we will provide further updates as they become available. We apologize for any inconvenience this may cause.