Mollie - External - Klarna: disruption – Incident details

All systems operational

External - Klarna: disruption

Resolved
Major outage
Started 3 days agoLasted 8 minutes

Affected

International payment methods

Major outage from 8:29 PM to 8:38 PM

Klarna

Major outage from 8:29 PM to 8:38 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified a major disruption external to our platform affecting Klarna payments.

    Consumers may experience failures when attempting to pay using this payment method.

    We are working to resolve the issue and will provide updates as they become available.