Mollie - Merchant Settlement / Payout Delay – Incident details

All systems operational

Merchant Settlement / Payout Delay

Resolved
Degraded performance
Started 1 day agoLasted about 1 hour

Affected

Settlements (Payouts)

Degraded performance from 9:56 AM to 10:55 AM

Settlement

Degraded performance from 9:56 AM to 10:55 AM

Updates
  • Resolved
    Resolved

    All settlements have been successfully sent to our bank and should arrive on your bank account before end of day.

  • Identified
    Identified

    We have identified a disruption affecting settlements / payouts. You may receive them later than anticipated.

    We will provide updates as soon as they become available.