Started over 1 year agoMonday 03 March 2025Lasted about 2 hoursMonday 03 March 202500:3602:30UTC
Updates
Resolved
UTC
Resolved
UTC
Maintenance has been completed successfully.
Monitoring
UTC
Monitoring
UTC
We are observing a recovery of services and will continue to monitor the situation.
Identified
UTC
Identified
UTC
A maintenance is causing a disruption for Bancontact.
You might experience intermittent unavailability and a decrease in conversion for Bancontact payments between 2025-03-03 01:30:00 & 2025-03-03 03:30:00 CET.