Mollie - External - Twint: minor disruption – Incident details

All systems operational

External - Twint: minor disruption

Resolved
Degraded performance
Started 15 days agoLasted about 1 hour

Affected

Local payment methods

Degraded performance from 8:14 AM to 9:41 AM

Twint

Degraded performance from 8:14 AM to 9:41 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Twint is experiencing a minor disruption that is affecting Twint payments. 

    You may see a decline in successful Twint payments as consumers may be unable to complete Twint payments. 

    We will provide updates as they become available.