Mollie - External - Twint - Major disruption – Incident details

All systems operational

External - Twint - Major disruption

Resolved
Major outage
Started 4 days agoLasted 6 minutes

Affected

Local payment methods

Major outage from 8:15 AM to 8:21 AM

Twint

Major outage from 8:15 AM to 8:21 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are observing a recovery of services and will continue to monitor.

  • Investigating
    Investigating

    We are currently investigating a major disruption affecting Twint payments.

    You will see a decline in successful Twint payments as consumers are unable to pay.

    We are in contact with Twint and are closely monitoring the situation. We will provide further updates as soon as we have more information.