Mollie - Merchant Payout Delay – Incident details

Bancontact experiencing degraded performance

Merchant Payout Delay

Resolved
Degraded performance
Started 26 days agoLasted about 5 hours

Affected

Settlement / Payout

Degraded performance from 9:50 AM to 2:30 PM

Settlement

Degraded performance from 9:50 AM to 2:30 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified a disruption affecting your payouts. You may receive your payout later than anticipated.

    We will provide updates as soon as they become available.