Mollie - External: Trustly full disruption – Incident details

All systems operational

External: Trustly full disruption

Resolved
Major outage
Started 4 months agoLasted about 4 hours

Affected

Local payment methods

Major outage from 5:49 AM to 10:00 AM

Trustly

Major outage from 5:49 AM to 10:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified an external full disruption affecting Trustly payments. You may see a decline in successful payments.

    We are working with our partners to resolve the issue and will provide updates as they become available.