Mollie - External: iDEAL: major disruption – Incident details

All systems operational

External: iDEAL: major disruption

Resolved
Major outage
Started 17 days agoLasted 6 minutes

Affected

Local payment methods

Major outage from 9:54 AM to 10:00 AM

iDEAL

Major outage from 9:54 AM to 10:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We experienced a major disruption affecting iDEAL payments.

    A fix has been implemented and we are monitoring results. We will provide updates as they become available.