Mollie - External - iDEAL: major disruption at ABN AMRO – Incident details

All systems operational

External - iDEAL: major disruption at ABN AMRO

Resolved
Partial outage
Started 4 months agoLasted 20 minutes

Affected

Local payment methods

Partial outage from 2:50 PM to 3:10 PM

iDEAL

Partial outage from 2:50 PM to 3:10 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    ABN AMRO is experiencing a major disruption affecting iDEAL payments. 

    You may see a decline in successful iDEAL payments as consumers may be unable to complete iDEAL payments using ABN AMRO. 

    If you want to monitor this issue, please check: https://beschikbaarheid.iDEAL.nl 

    We will provide updates as they become available.