Mollie - Dashboard disruption – Incident details

All systems operational

Dashboard disruption

Resolved
Degraded performance
Started 4 months agoLasted 18 minutes

Affected

Platform availability

Degraded performance from 1:40 PM to 1:58 PM

Mollie payment-links (Plink)

Degraded performance from 1:40 PM to 1:58 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified a disruption affecting our dashboard functionality. You may experience a degraded performance in relation to viewing Payment Links.