Mollie - Payment Links: major disruption – Incident details

All systems operational

Payment Links: major disruption

Resolved
Major outage
Started 22 days agoLasted 38 minutes

Affected

Platform availability

Major outage from 11:48 AM to 12:26 PM

Mollie payment-links (Plink)

Major outage from 11:48 AM to 12:26 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We have identified a major disruption affecting Payment Links.

    You may see a decline in successful Payment Links payments as consumers are unable to pay using Payment Links.

    We are working with our partners to resolve the issue and will provide updates as they become available.