Mollie - External - Cards - American Express: partial disruption – Incident details

All systems operational

External - Cards - American Express: partial disruption

Resolved
Partial outage
Started 24 days agoLasted about 1 hour

Affected

International payment methods

Partial outage from 7:16 AM to 8:28 AM

Cards — American Express

Partial outage from 7:16 AM to 8:28 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified a minor disruption external to our platform affecting card payments using American Express cards.

    You may see a decline in successful card payments as consumers may be unable to pay using their American Express credit card.