Mollie - Belfius: full disruption – Incident details

All systems operational

Belfius: full disruption

Resolved
Major outage
Started about 1 month agoLasted about 3 hours

Affected

Local payment methods

Major outage from 8:59 AM to 10:43 AM

Belfius Pay Button

Major outage from 8:59 AM to 10:43 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified the issue and are working with our partners to resolve the issue.

  • Investigating
    Investigating

    We are currently investigating a full disruption affecting Belfius payments. 

    You will see a decline in successful Belfius payments as consumers are unable to pay using Belfius.

    We will provide updates as they become available.