Scheduled for Wednesday 17 January 2024 at 01:00 – 08:01
Affects
Updates
Completed
Wednesday 17 January 2024 at 08:01
Completed
Wednesday 17 January 2024 at 08:01
The scheduled maintenance has been completed.
In progress
Wednesday 17 January 2024 at 01:01
In progress
Wednesday 17 January 2024 at 01:01
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Update
Wednesday 17 January 2024 at 00:00
Planned
Wednesday 17 January 2024 at 00:00
Maintenance will begin as scheduled in 60 minutes.
Planned
Monday 08 January 2024 at 11:22
Planned
Monday 08 January 2024 at 11:22
A scheduled maintenance window has been announced by AMEX on the 17th of January 2024 from 04:00 CET until 11:00 CET.
During this 7-hour window, AMEX expects to be unavailable several times for a period of 10 minutes.
You may therefore experience intermittent unavailability and a decrease in conversion on AMEX-branded Card payments.